1

I'm having an issue where a user is uploading images but they're not showing up correctly. The photo is listed in /admin/assets and shows the correct file size, kind, dimensions, etc but I'm getting a 404 error on the file's url.

I seem to able to upload images without issue myself.

  • Looking through my database, I can see the asset data in craft_assetfiles but it's not included in craft_assetindexdata. – Enaud Sep 26 '16 at 20:29
2

My first step to troubleshooting this is to confirm that the Asset Source URL is correct in the source settings.

|improve this answer|||||
  • Yep, that was my first reaction, too. Everything seems in order. When I view the asset, it directs me to what should be the correct url - but I'm served with a 404 page instead of the image. There are other images that are working nicely on the site (most of which I've pushed up from my local machine) that follow the same url structure. – Enaud Sep 26 '16 at 18:15
0

Turns out this was an issue with hosting on Heroku. Heroku apps cannot write to the file system.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.