1

Running Craft CMS 2.6.2903 and Redactor I 1.1.0

This is my config:

{
    "buttons": ["format", "bold", "italic", "lists", "image"],
    "plugins":["fullscreen", "source"],
    "toolbarFixed": true
}

fullscreen and source no longer work, not sure but possibly a recent Craft update? I have all my rich text fields set to Rich Text (Redactor I) and Standard as Standard.json is the config I edited for above settings. No html or source button shows up, fullscreen shows up but doesn't work.

Anyone know what could possibly be wrong, this config worked a while back.

  • The source plugin has never been included in Redactor I (github.com/pixelandtonic/RedactorI/commits/…). Just tested fullscreen and it worked on the latest Craft 2.6.2931 and Redactor I 1.1.0 and it worked fine locally. Check your browser's console for any JS errors. – Brad Bell Sep 12 '16 at 23:07
  • Fullscreen js error Uncaught TypeError: this.button.changeIcon is not a function example.com/index.php?p=admin/resources/redactori/lib/redactor/… I had source working before, is there not an option to view source/html etc? – Bowenac Sep 13 '16 at 3:23
  • html as a button doesn't work either, if you don't mind me asking what does your config look like for 1.1.0? – Bowenac Sep 14 '16 at 18:43
  • Maybe you just need to re-upload the Redactor I files? Sounds like some are maybe missing. Was just using the stock configs: github.com/pixelandtonic/RedactorI/tree/master/config/redactor – Brad Bell Sep 15 '16 at 4:26
  • Updated the files, still didn't work, clicked uninstall, then installed again and its back, not sure what happened. – Bowenac Sep 16 '16 at 2:57
1

Updated the files, still didn't work, clicked uninstall, then installed again and its back, not sure what happened.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.