3

I'm using WampServer Version 3.0.4 64bit on Windows 10 to run a local dev site. It's been working fine for a few weeks, and I last opened the site about 5 days ago. Today when I go to my site, I'm getting this error:

Craft CMS requires the PHP multibyte string extension in order to run. Please talk to your host/IT department about enabling it on your server.

I checked my PHP extensions menu in Wamp, and there is a check mark next to php_mbstring, so it seems to be enabled.

When I go to localhost in my browser to view my Wamp home page, I see the following error:

* ERROR * The PHP configuration loaded file is: - should be: c:/wamp64/bin/apache/apache2.4.18/bin/php.ini or c:/wamp64/bin/php/php5.6.19/phpforapache.ini

I don't know if this is new, but I haven't changed anything in my wamp configuration files since the site was working.

Full Wamp configuration, in case it's helpful: Here's my wamp setup

I'm fairly new to both Wamp and Craft, so not sure where the problem lies. Thanks in advance for any help!

2

As these things go, after I posted my question, I clicked "Refresh" in the Wamp menu and now my site works. I'm not sure what changed, especially since I already restarted the entire program several times, but all's well that ends well.

Configuration after refreshing: new wamp config

1
  • Update: I think maybe I didn't shut down Wamp properly the previous time? I just got the error again, and I think that may be what happened. – Katie Fritz Aug 24 '16 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.