3

I am retrieving a data set with about 5000 records and I am using the EntryModel::populateModels($results) to populate the model, this is causing a 500 error. When I limit the number of records returned to 100, it is working fine but when i set the limit to null it throws the error.

There isnt any error logged in the logs, and nor can it be a timeout because it only takes about 5 secs to return the error.

2

There's probably an error in craft/storage/runtime/logs/phperrors.log and there's a 99% chance the problem is you're hitting your php.ini file's memory_limit setting.

Populating 5,000 models is going to take a significant amount of memory.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.