2

I'm having a problem installing locally on my Mac (using MAMP Pro, Sequel Pro). I followed all the steps in the Mijingo installation video - plus a few others. When I go to install Craft CMS I get the following error message:

Service Unavailable Our site is temporarily unavailable. Please try again later."

I checked terminal and .htaccess appears hidden under the public directory. I changed the permissions. And the config file appears to be pointing in the correct places.

What might I be missing? ...or at the very least, how do I delete and start again fresh? Is it as simple as deleting the Craft files and starting over again or are there hidden files that need to be addressed before I can start clean again?

4
  • There is no other error message. Just a box with the text referenced. – Hellyar Aug 8 '16 at 14:53
  • 4
    Have you visited the /admin path? Sometimes I get this error when I need to finish updating or creating the db. – Rockwell Rice Aug 8 '16 at 15:55
  • 1
    @RockwellRice ...well now I feel stupid. I was launching from MAMP instead of typing the URL in my browser. So, yeah that worked. Thanks – Hellyar Aug 8 '16 at 17:25
  • 1
    @Hellyar Can you add what worked for you as an official answer? Will help in case someone else runs into the same problem. – Brad Bell Aug 8 '16 at 17:34
1

It sounds like you're missing permission on a folder in the /craft directory. Best thing to do, is just retrace your steps by following the official install guide.

I don't use MAMP though, so there might be extra stuff you need to do, but if you scroll down to the bottom of that page to the Additional Resources section. There are some other links to articles which might help, in particular this one:

Installing Craft CMS on Mac OS X Using MAMP & Sequel Pro

If you do want to start again then you should be safe to delete the /craft folder and try again. Although unless you're missing files, you shouldn't really need to start again.

4
  • 1
    First, thanks... That is exactly what I did. I first tried using the Mijingo approach, which to me seems identica as a73cram5ayl. Then I ran it exactly as outlined by a73cram5ay under Additional Resources. Either way, I still get the same "Service Unavailable" error message, with no other error reference, etc. – Hellyar Aug 8 '16 at 16:15
  • Is there a way (in terminal) to check the permission for each file to see if the chmod -R 744 craft/app took? I tried using the command ls -l app, ls -l config and ls -l storage. But, 744 does not appear in any of the lists. – Hellyar Aug 8 '16 at 16:24
  • see above, I just tried a 4th time with a clean install. I'm still getting the same error. Thoughts? This is kind of sad. – Hellyar Aug 8 '16 at 17:14
  • @hellyar ls -lah will give you a list and permissions of folders / files, but to me it seems that you might not be able to connect to the database. Please try your url and point to /admin it might give you a more useful error message – mike-orez Jan 4 '17 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.