3

We have a very strange issue here. On my computer I'm trying to save an entry. The process indicator keeps spinning for about five minutes before this exception comes up:

CDbException

CDbCommand faalde tijdens het uitvoeren van volgend SQL statement: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away. The SQL statement executed was: SELECT `locale` FROM `craft_locales` ORDER BY `sortOrder`

It's triggered by this function:

$this->userSession->checkPermission('accessCpWhenSystemIsOff')

On first look this definitely looks like a server issue. But... when I test this on a windows computer, it never happens. It's just not saving from an osx computer (browsers tested on osx: chrome, safari, firefox). Also tested on different osx computers and different windows computers. All with the same result. Windows works, osx doesn't.

Does anyone have a clue what might be going on here? Thanks!

  • That very much sounds like a bug. I recommend filing a bug report with Pixel & Tonic, as outlined here... – Lindsey D Aug 5 '14 at 16:24
  • @LindseyD No idea what the issue is, but I'm guessing it's server side. Works fine from my OSX and Windows boxes. – Brad Bell Aug 5 '14 at 16:51
  • Is this the native OSX MySQL (i.e. not MAMP)? Try restarting the MySQL server. – Marion Newlevant Aug 5 '14 at 17:44
  • Hi Sorry I haven't get back at this. We still have the problem and we are looking to solve it with the hosting company. @Marion Newlevant. It's happening on a remote server. The computer accessing it is Mac or Win. Win is working Mac isn't. – Dion Snoeijen Aug 8 '14 at 17:08
4

I had the same issue. Tried setting a bunch of mysql and php configs for timeouts, packet sizes, etc, and nothing would help. Finally found that turning off dev mode fixed it for me. Don't know why. Just thought I'd throw that out there in case someone else was having the same problem.

| improve this answer | |
  • 1
    Just want to note that I was getting the same error, but triggered from a different source. Disabling dev mode, then re-enabling it fixed the issue. – Arms Feb 28 '15 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.