As of July 2016, PHP branch 5.5 is unsupported. The PHP version my server currently is running is 5.5.9 which implies that the server will not receive any security updates going forwards.

I'm told that Craft recommends using 5.7. Is there any danger that parts of my website may stop working if the PHP is updated?


2 Answers 2


Don't worry, you should be fine.

Craft currently supports a minimum of PHP 5.3. Any higher version of PHP is also compatible.

When Craft 3 ships (late 2016 / early 2017), it will require a minimum of PHP 5.6.

Side note... If you're about to upgrade PHP, I highly recommend switching to PHP 7. The performance boost is notable, and should speed up your site by about 50-80%!


What OS are you running? Since you mentioned PHP 5.5.9, it sounds like you might be running Ubuntu 14.04 (Trusty), which is a LTS release.

Unless you're using a 3rd party package (like a Ubuntu PPA) or compiled PHP yourself, 5.5 isn't suddenly going to stop being supported.

CentOS/RHEL or a Ubuntu LTS release all have long term support that backport any security fixes if necessary to the older distros. (What's confusing is you might be getting security fixes from, say 5.5.34, but the package maintainers don't bump the version because you're not actually running it. This is a common false positive in PCI compliance scans, for example.)

In these kinds of things, I would spin up a VPS or fire up MAMP and test the install yourself. While Craft itself runs fine in my experience, you could run into trouble with plugins.

That said, I'll echo Lindsey's answer and agree that PHP 7 screams. Skip the 5.x branch if you're not running any other software and jump on 7 if you plan to upgrade because you'll be upgrading to it at some point anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.