1

I keep getting an error when I am in the CP. The stack trace of the error that is logged is below:

2016/08/02 01:12:05 [error] [exception.Craft\HttpException.404] exception 'Craft\HttpException' in /home/capspacedevhosti/craft/app/controllers/TemplatesController.php:59
Stack trace:
#0 [internal function]: Craft\TemplatesController->actionRender('(X(1)S(q325ycaz...', Array)
#1 /home/capspacedevhosti/craft/app/framework/web/actions/CAction.php(109): ReflectionMethod->invokeArgs(Object(Craft\TemplatesController), Array)
#2 /home/capspacedevhosti/craft/app/framework/web/actions/CInlineAction.php(47): CAction->runWithParamsInternal(Object(Craft\TemplatesController), Object(ReflectionMethod), Array)
#3 /home/capspacedevhosti/craft/app/framework/web/CController.php(308): CInlineAction->runWithParams(Array)
#4 /home/capspacedevhosti/craft/app/framework/web/CController.php(286): CController->runAction(Object(CInlineAction))
#5 /home/capspacedevhosti/craft/app/framework/web/CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#6 /home/capspacedevhosti/craft/app/framework/web/CWebApplication.php(282): CController->run('render')
#7 /home/capspacedevhosti/craft/app/framework/web/CWebApplication.php(141): CWebApplication->runController('templates/rende...')
#8 /home/capspacedevhosti/craft/app/etc/web/WebApp.php(279): CWebApplication->processRequest()
#9 /home/capspacedevhosti/craft/app/framework/base/CApplication.php(184): Craft\WebApp->processRequest()
#10 /home/capspacedevhosti/craft/app/index.php(62): CApplication->run()
#11 /home/capspacedevhosti/public_html/index.php(19): require_once('/home/capspaced...')
#12 {main}
REQUEST_URI=/(X(1)S(q325ycazg05lq11ktn1hqjtx))/copyright
---
2016/08/02 01:12:05 [error] [application] 

Anyone knows how to fix it?

1

The error you're showing from the logs is a simple 404 error that occurs whenever someone or something requests a URI on your site that doesn't resolve to anything. In this case it is /(X(1)S(q325ycazg05lq11ktn1hqjtx))/copyright, which is likely a script probing for vulnerabilities, which is very common for any public website.

We've moved those 404 messages into their own 404.log file in the upcoming Craft 3 so they don't clutter the main log file.

The underlying error message for An unknown error occurred will be elsewhere in your log files. Sometimes it's helpful to nuke all of your logs (or move them somewhere else), then reproduce the issue as you'll have left to sift through.

| improve this answer | |
  • The thing is that I get this error when I go to any page on the CP and it gives a flash message saying "Unknown error occurred", when I do a network monitor it doesn't indicate that I went to the "/(X(1)S(q325ycazg05lq11ktn1hqjtx))/copyright" url. Is there a way to disable this flash notice? – user2997606 Aug 3 '16 at 19:39
  • +1 for "We've moved those 404 messages into their own 404.log file in the upcoming Craft 3" – Lindsey D Aug 3 '16 at 19:48
  • @user2997606 if you want to reproduce the issue, then zip up your craft/storage/runtime/logs files and send them to support@craftcms.com, we can take a look. – Brad Bell Aug 3 '16 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.