2

I updated to the latest version of Craft, and I am getting this error:

Could not find your craft/ folder. Please ensure that $craftPath is set correctly in /storage/xxxxxxx/www/public_html/index.php

I have updated the same way each time. This is the first time I am seeing this error.

The files are setup like this:

Server

  • www/
    • craft/
    • public_html/
      • index.php

This is what the index.php file has always been:

https://cl.ly/281K2H3a3r1y

Permissions are the same as the previous app folder: 775

Any ideas about what may be causing this? As I said, I have updated Craft several times before without any problems. I've also read other threads on this and didn't find a solution that works for me. I am wondering why this would be a problem now, when it hasn't been an issue during previous Craft updates?

Thank you for any help you can give!

1

Actually, the permissions have been 774, not 775 as mentioned in my post. I think that was messed up somehow during the upload, and I missed that it wasn't the correct setting. I had also cleared my firewall cache earlier and it hadn't worked. When I cleared again just now after resetting permissions, everything seems ok.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.