7

I'm stuck on the /admin/install page, getting an error "Can't run Craft :(" saying that Mcrypt is required.

I've tried installing with Homebrew, but kept getting an error. So, I installed mcrypt manually using these instructions on Stack Overflow. PHP and Mcrypt are installed:

$ which php
/usr/local/bin/php

$ which mcrypt
/usr/local/bin/mcrypt

And in my php.ini file I've added:

extension=mcrypt.so

(I've also tried including the path extension=/usr/local/bin/mcrypt.so)

In the ;extension area (around line 880).

Even after restarting Apache, I still get the same error that "Mcrypt isn't installed" from Craft.

  • Were you able to get this to work? I've done the same and also attempted the brew installation with no luck. Any info would be greatly appreciated. Thanks! – user2280 Feb 8 '15 at 19:29
6

Here's all you need:

http://topicdesk.com/downloads/mcrypt/mcrypt-download

Works like a charm.

Update: to use brew, you have to specify the version of PHP for it to work. For example:

brew install mysql php54-mcrypt
  • This doesn't work in Yosemite – Holland Jun 25 '15 at 14:24
  • Did anyone figure out what does work in Yosemite? I'm getting the same error. – Ian Aug 19 '15 at 16:55
  • It's a gigantic pain in the neck, but I followed the instructions here and got it working just fine: michaelgracie.com/2014/11/… – Nathan D Huening Aug 20 '15 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.