2

I previously ran Vesta CP on Ubuntu and wanted to run something a little faster so chose centOS7 minimal. Installed Vesta CP and restored my backup. All my sites are running fine. Except for the ones running Craft CMS.

I would like to stress that the backup worked perfectly before

I get the error "Please ensure that $craftPath is set correctly" Now I'v been (honestly) trying for the past 6 hours to fix this on my own but I can't figure it out.

PHP runs as adminBOB (determent using: ) And checking my chmod the user and group are adminBOB:adminBOB (same as if I make a new folder or upload a new file)

Apache/httpd runs as "apache:apache" changing the owner of all my files for this site doesn't make the error go away either.

I'm also my http.conf (and tried php.ini) configured to have:

php_admin_flag safe_mode off

php_admin_value open_basedir none

So I'm almost certain those two are not on. Everything (folder/files) wise is the same. Same control panel (that installs all services)

I have no idea what to do next to try and get CraftCMS working again. Please assist! Thank you!!

  • If I move my /craft/ folder (and adjust the index.php setting) Craft works. But I really want to have it outside of the public_html folder. So it's not a craft specific problem, but something else? – Kitsune Jul 11 '16 at 20:15
  • By chance do you have something like Suhosin or mod_security installed? – Brad Bell Jul 11 '16 at 20:23
  • Thanks for the fast response. Just checked with phpinfo(); does not show mod_security nor Suhosin. – Kitsune Jul 11 '16 at 20:29
  • I'm no sysadmin, but what happens if you change PHP to run under the apache:apache user and group? – Brad Bell Jul 11 '16 at 23:26
  • No worries. I did try that. "chown -R user:grouphere /home/kitsune/web/" (holds all my websites) where user:grouphere had any possible combination. PHP appears to be running as root (lsof -i | grep :http) – Kitsune Jul 12 '16 at 9:37
2

So as it turns out Vesta has a funny way of handing httpd config files. There was another one tucked away somewhere where "open_basedir" They are kept in "/home/admin(username)/conf/web/httpd.conf"

Removing that fixed it.

Such a pain, tooks me hours to figure out something so simple. I had already removed it from the httpd.conf in the default location.

Something to keep in mind if anyone has the error and is running VESTA CP!

| improve this answer | |
  • Glad you got it sorted! – Brad Bell Jul 12 '16 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.