1

Is there a way to omit index.php from the URL when using IIS server? Adding

'omitScriptNameInUrls' => true,

seems to break the site (except for the front page). index.php is removed from the menu links, but when called the sub-pages result in a 404.

This is my first Craft site on IIS, and I have no experience with IIS. It is the client choice unfortunately.

1

I'm running the latest IIS 10 on Windows 10 and "pretty URLs" (i.e. craft.dev/admin/dashboard worked out-of-the-box using Craft's stock web.config file in the public HTML folder with no modifications.

I'd double check you've got that file in place and haven't made any modifications to it.

| improve this answer | |
  • Thanks Brad. Yes, that was the problem. The server owner had disabled the file because with it on the server would throw errors (500 if I recall). It hasn't been fixed so I have just had to go ahead with index.php in each URL. – Jack McKenzie Aug 3 '16 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.