1

I've installed Craft Commerce locally on MAMP Pro a few times. When I click the install button it takes awhile and then finally I get a 500 Error.

My Apache Log shows only these two lines:

[Thu Jun 09 15:09:06 2016] [error] [client ::1] FastCGI: comm with server "/Applications/MAMP/fcgi-bin/php7.0.0.fcgi" aborted: idle timeout (30 sec), referer: http://craft-prototype.dev/admin/settings/plugins
[Thu Jun 09 15:09:06 2016] [error] [client ::1] FastCGI: incomplete headers (0 bytes) received from server "/Applications/MAMP/fcgi-bin/php7.0.0.fcgi", referer: http://craft-prototype.dev/admin/settings/plugins

After I receive the error if I go to /admin/settings/plugins the plugin will show as installed and it's completely fine. The issue doesn't happen when I try to uninstall it. The issue will still happen even if I uninstall and reinstall it.

I should also mention that the Craft CMS install and all other plugins are working great and I receive no other errors until this comes up.

I'm assuming this is probably a MAMP configuration issue. Has this come up for anyone else?

2
  • Damn. Yup, it's a dupe... this clearly fixed it for me. I found a similar solution that wasn't as clearly written so I couldn't get it going but the selected answer here solved it for me.
    – Tim Knight
    Jun 10 '16 at 19:37
  • Awesome, glad you're sorted! Going to to ahead and vote to close this as a dupe, then.
    – Brad Bell
    Jun 10 '16 at 21:47