2

I've been trying to setup my site on IIS, which runs fine on Apache, without success.

My setup is this (with rewrites) / (loads craft for the admin panel) /en (loads the english homepage) /fr (loads the french homepage)

The root works without any issues so the web.config does its job. The same web.config lives in the fr and en folder, but as soon as I try to get in there, I hit a 500.

If I remove the web.config from those 2 folders, I get the homepage of each language, but nothing for the entries.

Anywone knows how to get it to work ?

I'm also trying to get everything working with a single php file that checks for the lang in the p parameter and sets it, but Craft doesn't receive the good slug, even if I modify the p parameter to remove the language.

Thanks

4

Looks like it was only because I was missing the clear tag in my rules in the subfolders. Everything works like a charm now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.