2

I am trying to index 1.8GB of assets to an asset source on Craft.

I have created an Asset Source which points to the folder with all of the assets. When I select the Asset Source I want to update the index for and select "Go" the loading screen runs for a while, then shows me a confirmation checkbox, but nothing has happened.

4

While Craft appears to give you a success message when the Update Asset Index modal displays a pretty checkbox, when working with a large number of assets, if you don't see a loading bar appear or see the indexed assets afterwards, it's possible you are running into a memory issue, and that pretty checkbox is lying.

Likely, if you look at your craft/storage/logs/phperrors.log you will find a memory error. Try increasing the memory available to your Craft install or increasing the memory_limit in your php.ini settings and trying again.

1

Had the same issue. In my case there was no phperrors.log (according to Brandon, it will only exist if there have been any fatal PHP errors)

The error was instead logged to storage/logs/web.log, but even easier, you can view the error in the CP. Craft (as of version 3.0.12) does not show it to the user (hopefully that will change, see https://github.com/craftcms/cms/issues/3012), but currently you can show the errors (as advised by Brandon) by opening your browser's dev tools network tab before running the asset index utility, and keep track of the Ajax requests that get logged when the utility is running (XHR tab).

In my case the error was:

Malformed UTF-8 characters, possibly incorrectly encoded.

and I fixed it by running this on the files:

convmv -r -f windows-1252 -t UTF-8 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.