I created a Matrix field with 1 block type called "Logo" and 2 fields inside that: 1) a related entries field and 2) an image asset. I then created a global that has this Matrix field in it that allows you to create up to 4 logo blocks in the Matrix.

When I try to create any number of logo blocks, whether I add an asset, choose an entry, or both, I get this CDb error when saving the global.

I get that the error is saying it can't locate a column of data it needs, but I don't know what the cause could be. I've tried deleting my Matrix field and global and starting over, but it's the same error each time.

I've checked the asset group for the logo images and everything seems fine: everything's named properly, no missing images, did an asset index update. No dice.

Here's a screenshot of the full error. I'm working on my local machine and the front end is unaffected.

CDbException: Column not found

  • Did you delete a field at some point in this process?
    – Brad Bell
    Apr 21 '16 at 2:28
  • No, but I did mess with the organization of the image assets. Originally I nested the images to be like press > logos > footer-logos but then changed my mind after having originally set these fields up. I suspected this might have been responsible for the error, so I tried deleting my custom fields and starting over with the new asset structure.
    – Ryan
    Apr 21 '16 at 22:59
  • If you do a database dump can you search the schema and see if your tables have foreign key constraints setup? It sounds like they might be missing.
    – Brad Bell
    Apr 22 '16 at 0:02
  • I take it you mean export the db and do a search for CONSTRAINT or FOREIGN KEY?
    – Ryan
    Apr 22 '16 at 0:26
  • That's exactly what I mean.
    – Brad Bell
    Apr 22 '16 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.