4

I've updated several Assets Sources on my production site. I've exported / imported the database from production into local - the new Assets Sources are in place but the asset thumbs are now missing.

How can I get Craft to re-generate these please?

3

Go to Settings > Clear Caches. Should regenerate them all from the new source.

  • Yes, tried this - and 'Update Asset Indexes' from Settings too. But neither worked. – Matt Ellis Apr 19 '16 at 21:55
  • 1
    Have you double checked your asset path? – darylknight Apr 20 '16 at 8:07
3

My basePath was wrong in my config (due to a DropBox syncing issues). Once I corrected that and cleared caches, the asset thumbs reappeared.

2

I've had this issue before, and it was always either:

  • Needed to update the URL in Settings > General
  • Needed to change permissions on thumbs directory.
  • Needed to delete thumbs directory.
  • I'm setting the siteUrl in the config - so that part is correct. But where is the thumbs directory? – Matt Ellis Apr 19 '16 at 21:54
  • craft/storage/runtime/assets – Clive Portman Jan 19 '18 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.