1

Does anyone know where to set the passphrase for the PEM file that is configured in the Push Notification Plugin for Craft CMS?

I have created a new app and set the Certification Location to the PEM file location. I have tested on the server to confirm that the certificate and key files work. However, when I try to send a new alert -- I get the following error:

stream_socket_client(): Unable to set private key file 

Which I'm sure is due to the fact that I haven't told it what the passphrase is. However, I can't find any documentation that explains where to put this configuration setting.

Any help is greatly appreciated.

Plugin Github Reference: https://github.com/boboldehampsink/pushnotifications

2

From my research and testing, it looks like this plugin doesn't offer the option to set a passphrase for the PEM file. I had to create a new PEM file that doesn't require a passphrase in order to send a successful alert.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.