1

It looks like Apache (or Craft?) isn't routing all of the requests to index.php. So http://SITENAME/index.php?p=admin/install works, but http://SITENAME/admin/install doesn't. The issue is this is happening with every URL, so the HTML for the install page loads, but none of the assets (CSS, JS) do.

Here's my issue in picture form:

enter image description here

enter image description here

1

It sounds like you need to enable the .htaccess file in the root directory of your site.

By default, the .htaccess file included with Craft is named htaccess (without the period). The period needs to be added to the beginning of the file.

| improve this answer | |
  • .htaccess was enabled. I verified this via adding an invalid string to the .htaccess file, which caused index.php to give a 500 error (if I recall correctly) – lynn Mar 29 '16 at 9:06
1

Disabling the omitScriptNameInUrls config option makes it work. Not sure if this is a "solution" though

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.