1

I am trying to install Craft on my server and I've hit a snug which I can't overcome, because I am just not that technically proficient.

I think I've followed all of the instructions on the Craft website to a t, however when I tried to get to the admin panel, I get the following error:

Could not find your craft/ folder. Please ensure that $craftPath is set correctly in /home/toaeroplano/public_html/index.php

I did some Googling on that and I found out that this might be an issue with open_basedir permissions.

So I went to my php.ini file and I saw that this was edited out. Like this:

; open_basedir, if set, limits all file operations to the defined directory
; and below.  This directive makes most sense if used in a per-directory
; or per-virtualhost web server configuration file. This directive is
; *NOT* affected by whether Safe Mode is turned On or Off.
;open_basedir =

So I changed it to:

open_basedir = ON (and took the ; off)

So now I get a "No input file specified." message.

What can I do? Like I said, this is far from being my area of expertise.

Thank you

1

It's likely your /craft directory couldn't be found. Out of the box, Craft expects it's /craft directory to be located just outside the root directory of the website. So by the looks of it from your path, your index.php file is located here:

/home/toaeroplano/public_html/

So that would mean you /craft directory should be located here:

/home/toaeroplano/

If I were you I'd put the php.ini settings back to what they were so you get the original error, then make sure you've copied the /craft directory from the installation into the directory above. If you want your /craft directory somewhere else you need to edit the index.php and specify where the directory lives. So edit this line in index.php:

$craftPath = '../craft'; 

The .. in the path just means the directory above, so if you wanted it to live in the /home directory, you change it to this:

$craftPath = '../../craft';

EDIT: Also make sure the permissions on the /craft/app/, craft/config/ and craft/storage/ are set as per the install docs.

| improve this answer | |
0

open_basedir is actually expecting a path (like /home/toaeroplano) and some hosts use it as a form of "jailing" their users to help make sure PHP can't access anything from outside whatever value is set there.

As Steve mentioned in his answer, don't set it unless you know what you're doing. I don't know how you're hosting Craft, but some hosts will lock down the server in other ways—for example, mod_security might be preventing you from hitting anything outside the web root as well—in your case /public_html/—so you may have to set $craftPath to ./craft so it's looking in the same "folder" and move your craft folder to public_html.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.