2

I'm getting the following error when trying to send a campaign with Campaign Monitor through the Sprout E-mail plugin:

400: HTML Content URL Required

I used the example templates provided by Sprout. The Api connects well (I get the list my subscription list from Campaign Monitor in Sprout). I make a new campaign and I can preview the mail in both html and text. The preview looks fine (just some hardcoded stuff). But when I try to send the mail I keep on bumping on that issue. I figured it had to do something with the template url, so I played around with the setting in the campaign:

Entries of this type have their own URLs 

I tried pointing it to the template (sproutemail/newsletter) or the name of the entry (sproutemail/{slug}), both without any luck.

2

Had a typo in my template directory.

1
  • It's also worth noting that Campaign Monitor requires that your content be public. So, while live preview may work for your email locally, when submitting the email code to the Campaign Monitor API you will need to have your code in a web accessible location. – Ben Parizek Mar 21 '16 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.