1

We have a strange issue with a site we are developing. We have a user login on the front-end of the site which takes users to their profile pages. The issue we have is that on a Mac the user is being logged out randomly and irregularly on the local server.

This is odd because on PC this issue is not occurring. And what makes it even more strange is if the user is logged in as admin, whilst the user is logged out on the front-end they are still logged into the CMS?

Has anyone come across this issue before? I've tried some of the suggestions made in this post but nothing seems to be working.

Craft constantly logging out from admin area

  • If it were craftcms.stackexchange.com/questions/952/…, then it'd be happening consistently for everyone. 2 thoughts: 1) Something on the Mac browser you're using is messing with cookies which affect sessions (add-on, extensions, etc) and 2) your front-end template logic is wrong and when you think the user is logged out, they're actually not. – Brad Bell Mar 17 '16 at 22:00
1

Turned out to be a browser issue specific to one mac. And we also noticed that when using chromes device mode it seemed to kill the session!

  • Chrome's device model probably changes the user agent string, so you'd want to set this to false: craftcms.com/docs/… – Brad Bell Mar 23 '16 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.