2

When I add a new user in the admin area, they get a link to activate their account. On the screen that link goes to, they are prompted to set a password. After the password is submitted, they are returned to /dashboard. How do I alter that return? I have the following config variables set

'useEmailAsUsername' => true,
'autoLoginAfterAccountActivation' => true,
'activateAccountSuccessPath' => 'members/index',
3

Solved this by

0

The currently logic around that is "if the account has Access the CP permissions, send them to the control panel login page, otherwise, send them to wherever the activateAccountSuccessPath config setting is set to".

Since you've got autoLoginAfterAccountActivation set, the CP login page redirects to the CP dashboard.

If that's not the behavior you're looking for, you can create a plugin that mimics the necessary craft/app/controllers/UsersControllers methods changing the logic for your requirements as necessary.

  • 1
    Thanks Brad. This member group didn't have CP access. Seems like they should have gone to activateAccountSuccessPath - but they weren't. I x-posted with you what worked for me, it's probably better to deliver my own form anyway. – Christy Collins Mar 16 '16 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.