I'm a total S3 noob but would like to get it set up so that I can store Assets there. So far, I've:

  • created an AWS account (zing!)
  • created a bucket named mybucket
  • created a user in IAM myuser
  • assigned the AdministratorAccess policy to myuser*
  • created a new Asset source called s3
  • entered the user Access Key ID and Secret Access Key, which correctly shows me the mybucket destination
  • URL Prefix is auto-filled with http://s3.amazonaws.com/mybucket

OK! When I go to upload a file to the S3 source, I see the upload stripe go all the way across the page and the loading spinner happening at the top right of the page. But this process hangs and the file is never uploaded.

This is a tiny image, so I don't think it's a file size issue. No errors / warnings are produced. I don't see anything obvious in the logs.

Any help is appreciated! Thanks!


*I know that I'll eventually want a more restrictive policy but for the time being, just trying to get a Hello World working.

  • Sounds like an excellent opportunity to open a support ticket with us, providing logfiles in the process! Mar 4, 2016 at 14:37

1 Answer 1


I did end up opening a support ticket with Craft- they immediately suggested that this could be caused by a firewall. To which I scoffed! But after talking with some other folks in the office, this seems to be the case.

Unfortunately we never found a firewall solution to this problem. What did work was to assign a static IP to my computer that bypasses the http-proxy packet filter.

So yeah. Firewall. Dang.

  • Could you elaborate on this solution? I'm having the same problem now, and can't figure out how to get around it. There doesn't seem to be a firewall solution to this problem as S3 doesn't have a static IP that you can rely on hitting every time. I can upload when I try it on the remote server, but not on my local machine. So I'm guessing that setting a fixed IP on my machine as you said would be the solution. So what exactly did you do to bypass the http-proxy packet filter?
    – peirix
    Nov 24, 2016 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.