2

We have more than 100 authors in a user group, but when selecting an author for an entry, only the first 100 are listed in the (a-z) dropdown. Whats the best way to display them all (or up the parameter?)

2
  • Hey Simon, if you’re referring to the Author setting in the Edit Entry page of the Control Panel, then this sounds like a bug. FFR please send issues with the Control Panel over to P&T directly, either by sending an email to [email protected], or using the “Send a message to Craft support” widget on your dashboard. Jul 25, 2014 at 13:25
  • Ups, totally missed that you meant the control-panel...
    – Victor
    Jul 25, 2014 at 13:39

1 Answer 1

3

By default, Craft sets the limit of the ElementCriteriaModel to 100.

If you want to get all/more entries just set the .limit parameter to null or a number:

{% set allUsers = craft.users.limit(null).find() %}
{% set someUsers = craft.users.limit(200).find() %}

A list of all available parameters can be found here: craft.users

1
  • 1
    Found this rentetly when trying to build a sitemap. the null is a nice tip there. Thanks! Jul 25, 2014 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.