3

I have created an Asset field type and have the "restrict file types" option not checked.

When I attempt to upload a file with extension .PSD i get the message Upload failed for 020516_Action-Buttons_Desktop.psd. The error message was: “Error uploading the file: This file type is not allowed”

Is there a setting someplace else thats preventing this?

I also tried checking the restrict option and selecting "Photoshop file". But this also did not work.

9

You can add the psd extension to extraAllowedFileExtensions in your config file.

'extraAllowedFileExtensions' => 'psd'

https://craftcms.com/docs/config-settings#extraAllowedFileExtensions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.