0

I'm running the latest Craft and Sprout Forms as of today.

On a clean install of Sprout Forms whenever I create a new form (even with just one text input field), I cannot access that specific form's entries in the CP. The "All Entries" view works, however.

There are two "unknown error" notifications in the CP. Here are the relevant errors in the log.

2016/02/23 11:40:06 [error] [system.db.CDbCommand] CDbCommand::fetchAll()
failed: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'form' in 'on
clause'. The SQL statement executed was: SELECT `elements`.`id`,
`elements`.`type`, `elements`.`enabled`, `elements`.`archived`,
`elements`.`dateCreated`, `elements`.`dateUpdated`, `elements_i18n`.`slug`,
`elements_i18n`.`uri`, `elements_i18n`.`enabled` AS `localeEnabled`,
`entries`.`id`, `entries`.`ipAddress`, `entries`.`userAgent`,
`entries`.`dateCreated`, `entries`.`dateUpdated`, `entries`.`uid`,
`forms`.`id` AS `formId`, `forms`.`name` AS `formName`, `forms`.`groupId` AS
`formGroupId`, `form-request-an-audit`.`title`, `form-request
an-audit`.`field_test` AS `test`

~

2016/02/23 11:40:06 [error] [exception.CDbException] exception 'CDbException'
with message 'CDbCommand failed to execute the SQL statement:
SQLSTATE[42S22]: Column not found: 1054 Unknown column 'form' in 'on clause'.
The SQL statement executed was: SELECT `elements`.`id`, `elements`.`type`,
`elements`.`enabled`, `elements`.`archived`, `elements`.`dateCreated`,
`elements`.`dateUpdated`, `elements_i18n`.`slug`, `elements_i18n`.`uri`,
`elements_i18n`.`enabled` AS `localeEnabled`, `entries`.`id`,
`entries`.`ipAddress`, `entries`.`userAgent`, `entries`.`dateCreated`,
`entries`.`dateUpdated`, `entries`.`uid`, `forms`.`id` AS `formId`,
`forms`.`name` AS `formName`, `forms`.`groupId` AS `formGroupId`, `form
request-an-audit`.`title`, `form-request-an-audit`.`field_test` AS `test`

I've uninstalled, re-installed, and everything in-between with the same outcome.

2

The form handle can't contain special characters like - or *, the validation of that field is not working, but we'll fix that in the next release. In the meantime please update the form handle.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.