3

Trying to upload images and get the following error

Upload failed for "filename". The error message was "Error uploading the file: The folder "/var/www/html/imgs/logos/" is not writable"

3

On the server, check:

  • if the folder exists?
  • Check the folder permissions are set to 777 (could probably reduce to 755)

Within Craft:

In: Settings > Assets > Asset Sources - make sure File System Path and URL fields, have no leading forward slashes e.g.

imgs/logos/
| improve this answer | |
  • Thanks for the fast response. The folder exist and craft asset settings are correct. Where do I change file permissions? – Devin Feb 19 '16 at 20:15
  • Of course. From within your FTP client, you should be able to right click on the folder and choose "file permissions". Normally you could tick some checkboxes or just type the chmod numbers e.g. 777 – Matt P Feb 19 '16 at 20:25
  • 2
    Changed permissions in FTP client. Still getting the same error. – Devin Feb 19 '16 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.