1

I'm having some trouble on a fresh install of Craft. I've uploaded all the files to my server and moved index.php (etc) out of the public folder and into the root directory.

I've also changed index.php's $craftPath to this:

$craftPath = './craft';

But I'm still getting a 404 error on the homepage. I've set permissions on the folders, but still nothing.

My file structure looks like this:

FTP

Any suggestions..?

2 Answers 2

2

Change this:

$craftPath = './craft';

to this:

$craftPath = 'craft';
2
  • Unfortunately that didn't do it, still getting the same error. 404 - File or directory not found.
    – Chrish
    Commented Feb 18, 2016 at 16:04
  • Not sure if it's helpful but /admin doesn't work either
    – Chrish
    Commented Feb 18, 2016 at 17:05
2

Contacted my host and for some reason PHP was not enabled as default on my account. This solved the problem.

1
  • Yup, that would do it! Well done Chrish :)
    – Matt P
    Commented Feb 19, 2016 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.