1

I'm having trouble in the control panel. I'm get logged out all the time and I can't find the reason. The "Your session has ended" modal window appears all the time, I can just do a refresh and it stays in the control panel (logged in). Sometimes i'm also thrown out completely.

What did i tried to solve it (together)

  • 'overridePhpSessionLocation' => true or false doesn't seem to make a difference
  • removed my cookies
  • craft/storage/runtime is on 777
  • removed database content of craft_sessions
  • removed craft/storage/runtime multiple times, it's created again.
  • craft/storage/runtime/sessions stays empty and is on 777

This is the error in the log files:

2016/02/09 20:31:12 [warning] [application] Tried to restore session from a cookie, but the given hashed database token value does not appear to belong to the given login name. Hashed db value: cf349cc791478ab96e9229dad6367f1358f1404bczozMjoiMGQ0SUJxelZYYmdNUVh6WDhVdHhBODFUb0lWb2dGT0wiOw== and loginName: REDACTED

(I edited the question to narrow down the problem. it's kinda driving me nuts)

1

in the end, for me making

/opt/www/dave/web/tmp 

writable for craft was the solution. thanks for all the feedback!

| improve this answer | |
  • Thanks Dave. Just to mention, if anyone is using WHM, then that setting will be in MultiPHP INI Edit, session.save_path Either setup a path to store the sessions or like I do use NULL. – Vin May 3 '17 at 8:20
0

Lots of stuff going on here.

Number 2 and 4 are symptoms of your session problems. Numbers 1 and 3 and most likely not related and should be their own, separate questions.

For your session issues, there are many things that could cause you to get logged out on the admin, but your specific error message indicates that something is interfering/tampering with the cookie that Craft uses to maintain session (the authentication hash in the cookie doesn't match the authentication hash that Craft saved in the database when the session was started).

To start debugging that first I'd disable any browser add-ons and make sure that you don't have any other authenticated sessions open on other browsers/tabs for the same domain while you're testing.

| improve this answer | |
  • 1. was solved with a reinstall with the correct htaccess. 3. seems to be solved with the last update 2.5.2762 2 - 4 are persistent. even in private browsing i have the issue. any idea where to search further? – Dave Driesmans Feb 10 '16 at 15:37
  • Also locally it works perfect – Dave Driesmans Feb 10 '16 at 16:06
  • overridePhpSessionLocation => false and removing craft/storage/runtime/ didn't help – Dave Driesmans Feb 10 '16 at 16:43
  • Try clearing all of your cookies for the site as well as what's in the craft_sessions table? Note if it's a live site that will log anyone with a session out. – Brad Bell Feb 10 '16 at 18:12
  • tried it out twice now but same situation – Dave Driesmans Feb 11 '16 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.