0

I have 3 locales set up - en_ca, fr_ca, en_us. en_us was selected when installing Craft. I had to change the default locale to en_ca and did so in general.php after installation. I'd like this change in the CP as well. Currently, entering new entries and the CP site link all still point to en_us.

How can I change the default locale?

  • 1
    Have you checked under "Locales" in Craft Settings? You need to change it here as well. – naboovalley Feb 8 '16 at 11:48
  • @naboovalley I've change the order so that en_ca is first, followed by en_fr and en_us. However I can't find a 'Set to default' option. – biko Feb 9 '16 at 2:24
  • As Brad Bell pointed out, changing my user's preferred locale solved the issue. Thanks for your help! – biko Feb 9 '16 at 3:19
2

You need to update the locale to en_ca in the control panel under Settings->Locales.

  • I've change the order so that en_ca is first, followed by en_fr and en_us. However I can't find a 'Set to default' option. – biko Feb 9 '16 at 2:25
  • The one in the top slot will be the "site default". You can override what the CP is displaying in for a user under their user account preferences. – Brad Bell Feb 9 '16 at 2:37
  • Perfect! Changing my user's preferred locale solved the issue. Thanks for the help! – biko Feb 9 '16 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.