0

I have a problem with upgrading to Craft 2.5 on a shared hosting platform. I have run the upgrade both automatically and also tried manually. It runs but when I try to update the database I get a fatal error message telling me to contact my server providers.

I believe the problem is the size of the database as there are 20000+ users and related user data. So it's 43mb which I think the shared hosting is having issues with.

As I am limited to what PHP limits I can change with shared hosting I am looking for a workaround.

My first thought is to empty the user tables from the database (which would reduce the size considerably), run the update and then add them back in. However I wanted to check if there were any database changes to the user tables in the upgarde. I'm looking at using version 2.5.2761

I've looked through the change log but can't see anything obvious.

Has anyone else come across this issue or are there any other better solutions?

Cheers

1

Have you checked craft/storage/runtime/logs to see if there's an error in there related to the update?

In case it is the database: you can disable the database backup during the update by changing https://craftcms.com/docs/config-settings#backupDbOnUpdate to false in general.php

Remember to make a database backup every time you run an update when you change that setting!

| improve this answer | |
  • Ok that worked for me. Now to go through all the plugins and see what's broken!! Cheers – Lettie Feb 2 '16 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.