I keep getting the following error when trying to update my craft installation.

mod_fcgid: read data timeout in 31 seconds, referer: https://mysite.com/admin/manualupdate/craft
End of script output before headers: index.php, referer: https://mysite.com/admin/manualupdate/craft

I have tried updating my /etc/apache2/mods-available/fcgid.conf file with:

FcgidConnectTimeout 600
FcgidIOTimeout 600
IdleTimeout 600
ProcessLifeTime 600
IPCConnectTimeout 600
BusyTimeout 600

And this has given no results. I still get the error. The database wasn't able to go rollback and the site is currently not available. Unfortunately this is happening in production...


  • nginx and php-fpm? I believe php-fpm has its own timeout settings as well.
    – Brad Bell
    Commented Feb 1, 2016 at 16:16
  • I was able to set the Maximum PHP script run time to unlimited via webmin. I'm assuming this translates to a configuration in the php.ini file. I'll update the post with the answer. Thanks!
    – cballenar
    Commented Feb 1, 2016 at 16:22

1 Answer 1


If running Webmin, check the Website Options under Server Configuration and set Maximum PHP script run time to unlimited or a largar value.

This is what finally did the trick but updating /etc/apache2/mods-available/fcgid.conf with the following values may have also played a role.

FcgidConnectTimeout 600
FcgidIOTimeout 600
IPCCommTimeout 600

After these changes and restarting apache, the script was finally able to finish and update the installation successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.