2

I'm running the latest version of Craft Craft Pro 2.5.2760 I've tried this on a vanilla install and on a current site where the issue was highlighted initially.

If I copy and paste "this is some text" into a richtext field, regardless of "Clean up HTML" and "Purify HTML" options being checked or not, when I press save or switch into and out of HTML mode I'm left with

 "this is" where the text within the <i> and <b> tags have been stripped out.

If the markup looks like

<p>this is <em>some</em> <strong>text</strong></p> 

everything is fine, nothing gets stripped out.

There is clearly an issue with

<i> and <b> and possibly other tags.

A work around I've found is using in a custom .json in the redactor folder in config.

pasteInlineTags: ['b', 'i']

which instantly removes the b and i tags on paste, however this removes the formatting that the user is trying to copy and paste in which kind of defeats the point of being able to copy and paste.

So I need a solution that will allow the copy and paste of content from word, or pages or another system where the b and i tags are not stripped out immediately.

Just to cover myself I have also tried removing all plugins to see if any of them were causing an issue but again this had no impact.

Thanks in advance for your help you lovely people.

  • I voted to close as off-topic as it seems to be a bug with Craft or it's implementation of the editor. You should probably report it to P&T, so they can look into it. – carlcs Jan 28 '16 at 21:17
  • It's definitely a Redactor bug and has been reported to Imperavi. Wondering if it wouldn't be helpful to leave it open? Seems like something someone else might ask, too. – Brad Bell Jan 29 '16 at 0:19
  • You're right @Brad, that close reason doesn't make too much sense. I removed the vote. – carlcs Jan 29 '16 at 1:19
  • I'm having the same problem. This is definitely a bug. If the 'source' plugin is enabled and you click the 'HTML' button in the toolbar, then back, any text inside <b> or <i> tags disappear. – Elliot Lewis Feb 11 '16 at 14:34
  • Looks like Redactor have fixed this in 1.2.2. imperavi.com/redactor/log/ Doesn't specifically say cut/paste but, "An issue with text inside of 'b' and 'i' tags not displaying" – Elliot Lewis Feb 18 '16 at 11:02
2

Imperavi fixed this in Redactor II 1.2.2, and we included that update in Craft 2.5.2763.

  • Wow, Redactor version released today and already in Craft! Thanks – carlcs Feb 19 '16 at 2:13
1

Thanks for the help, I've reached out to Brad @ Craft and the developers are Redactor, they've confirmed it's a known issue with Redactor and they're working on a fix.

  • That's great news, I hope a fix is coming soon. We've got a lot or Word content to cut/paste and from Word the markup has <i> and <b>. – Elliot Lewis Feb 11 '16 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.