0

I'm getting white blank page when trying to access my website and Craft login page. I haven't updated the website for few months. So I assume no files has been changed.

I checked with the hosting provider, and they say everything is okay on their part.

So I turned on the Dev Mode. And it came back with this error : Fatal error: Class 'Craft\HttpRequestService' not found in /home/alpw7814/craft/app/framework/YiiBase.php on line 213

What could possibly cause this? Is there anything I need to check? Thank you in advance.

  • Sounds like some of your core files are missing (or corrupted). Have you tried to re-download Craft; replacing the /craft/app folder with a fresh copy? – Mats Mikkel Rummelhoff Jan 26 '16 at 10:35
1

That error indicates that Craft is missing some files (or they are corrupted) in its craft/app folder. You can download a fresh copy of Craft from https://craftcms.com and replace your existing craft/app folder with the new one and that should resolve it.

| improve this answer | |
  • I see. I've tried replace app folder, and it's working now. Thank you. – Marissa Azaria Jan 27 '16 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.