1

For some reason whenever I add a custom column to a section's entry list I'm getting errors and no values.

If I add Entry Type to the column list, for example, it's saying:

Unknown class: Craft\EntryTypeModel

And links are saying:

Unknown class: Twig_Markup

screenshot of errors

I'm a little dumbfounded? I tried removing and re-adding them and still no luck. Any ideas?

6
  • Weird... I'd guess you're missing some craft/app files. Can you try replacing your existing craft/app folder with a fresh one downloaded from craftcms.com? – Brad Bell Jan 17 '16 at 3:31
  • Yea I tried that too, no luck? – Keith Mancuso Jan 17 '16 at 3:31
  • Can you verify craft/app/models/EntryTypeModel.php exists and its permissions are such that PHP can read it? – Brad Bell Jan 17 '16 at 3:33
  • If all that checks out, can you look in craft/storage/runtime/logs find the error and edit the original question to include the full stack trace for it? – Brad Bell Jan 17 '16 at 3:34
  • Ugh, im an idiot i had an old Plugin installed "DashCols" that was what was causing it of course. Sorry! – Keith Mancuso Jan 17 '16 at 3:44
2

So turns out it was an issue with an older plugin, DashCols. As soon as I disabled it things worked fine.

Unsurprising in hindsight!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.