Has anyone found a replacement for:

deniedTags: ['p'],
paragraphize: false

I can't find a way to strip the pesky <p> tag anymore, on Redactor II.

1 Answer 1


I guess with Redactor II you "manually" have to make sure you cannot create those tags with buttons/shortcuts or by pasting in rich text.

  • Button configuration works with the formatting and formattingAdd settings.
  • Paste config settings were added with Redactor II 1.2 (Craft 2.bla), the ones you're probably interested in are pasteBlockTags and pasteInlineTags.

Redactor II deprecated the paragraphize setting and automatically wraps each paragraph in <p> tags. If you also want to prevent <p> tags, removing them on a template level using a Twig filter like striptags is probably your best bet at the moment (→ see Redactor II Craft 2.5 Prevent Paragraphs).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.