I set up an matrix field and put it into section type.

If I am trying to create new entry a kind of broken 'Create a new entry' CP is shown up. Only title 'Create a new entry' and an broken 'save' button. Also rest of header seems not to rendered nice. Horizontal scrollbars appear.

If I change same field to other type, all works as expected. It really only happens if I am using matrix field.

All happens on fresh setup: No plugins installed. (Just this one task tried and failed). Mac, Mamp Pro. Craft (version 2.5.2757)

Console in Browser says nothing.

What I tried: + Fresh installation with user permissions for all craft folders read&write. + PHP memory config on 128mb. (Mamp Pro).

UPDATE: SOLVED It had something to do with php error settings in Mamp Pro. Once disabled, all is working, also with Matrix.


2 Answers 2


Solution: Do it as in craft instructions asked 'PHP 5.3.0 or later with safe mode disabled' and all works perfect like a charm.

This problem came from settings in Mamp Pro. The debugger was active. And all other 'what to log' too. After uncheck - no problem any more.


Same issue here -- could be a PHP one. I solved it by increasing the max_nesting_level to something like 200. Add/edit the following line in your php.ini:

xdebug.max_nesting_level = 200

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.