2

I have a local site that was running perfectly, but last year when I ran the auto-update it seems that it did not finish the process. At that time didn't have time to have a look to what happened (please bear in mind I'm a designer, and this is not a client site :D), and yesterday I saw that the admin dashboard was not working, and some pages were not loading too.

I downloaded the files again from the website, replaced the craft/app folder following the manual update instructions, and all seem to be fine (site works and dashboard works), except that when I go to entries I get this error:

CDbCommand failed to execute the SQL statement: SQLSTATE[42S02]: Base table or > view not found: 1146 Table 'craft.craft_elementindexsettings' doesn't exist

Other pages of the admin side works fine, I've cleared the cache and that made no difference.

When I uploaded the new craft/new and went to /admin, I did not get any message about updating the database as the instructions say.

I also can't recall why the auto-update didn't work properly. I kind of remember that the page got stuck, or I got an error, but as the internet in this office is quite bad, I thought the problem was at my end, not craft.

Any ideas on how to solve it? Is it possible to re-run the auto-update of the database?

2

This issue has actually come up before in the Slack channel...

"That’s a brand new Craft 2.5 table, so you’ve probably tried to do the update before, it failed and you didn’t clear out all tables from the database when you retried." - Brad Bell

As you mentioned, your auto-update did not complete successfully. So the logical next step (as you tried) is to perform a manual update.

But here's the catch... Before you made your 2nd (manual) attempt, you didn't roll back your database. Between attempts, you would need to drop all tables and re-import your original database SQL file.

  • I dropped all the tables and re-import my latest SQL file. Craft asked me to update the database and did not return any error. But now when adding a new entry I get this error: Internal Server Error Craft\EntryElementType and its behaviors do not have a method or closure named "defineTableAttributes". – Alex Lillo Jan 7 '16 at 14:14
  • Sounds like your app folder might be corrupt. Try replacing it with a fresh copy. – Lindsey D Jan 8 '16 at 19:56
  • Seemed to be the problem, finally managed to install an old 2.4.x version to leave it working in a pre-update way. Thanks! – Alex Lillo Jan 9 '16 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.