0

Using, https://github.com/pixelandtonic/ContactForm

I recently migrated the server to a new server and now i get:

2015/12/03 19:21:27 [error] [exception.phpmailerException] exception 'phpmailerException' with message 'SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting' in C:\inetpub\wwwroot\craft\app\vendor\phpmailer\phpmailer\class.phpmailer.php:1256 Stack trace:
#0 C:\inetpub\wwwroot\craft\app\vendor\phpmailer\phpmailer\class.phpmailer.php(1100): PHPMailer->smtpSend('Date: Thu, 3 De...', 'This is a multi...')
#1 C:\inetpub\wwwroot\craft\app\vendor\phpmailer\phpmailer\class.phpmailer.php(1004): PHPMailer->postSend()
#2 C:\inetpub\wwwroot\craft\app\services\EmailService.php(435): PHPMailer->send()
#3 C:\inetpub\wwwroot\craft\app\services\EmailService.php(77): Craft\EmailService->_sendEmail(Object(Craft\UserModel), Object(Craft\EmailModel), Array)
#4 C:\inetpub\wwwroot\craft\plugins\contactform\services\ContactFormService.php(54): Craft\EmailService->sendEmail(Object(Craft\EmailModel))
#5 C:\inetpub\wwwroot\craft\plugins\contactform\controllers\ContactFormController.php(100): Craft\ContactFormService->sendMessage(Object(Craft\ContactFormModel))
#6 C:\inetpub\wwwroot\craft\app\framework\web\actions\CInlineAction.php(49): Craft\ContactFormController->actionSendMessage()
#7 C:\inetpub\wwwroot\craft\app\framework\web\CController.php(308): CInlineAction->runWithParams(Array)
#8 C:\inetpub\wwwroot\craft\app\framework\web\CController.php(286): CController->runAction(Object(CInlineAction))
#9 C:\inetpub\wwwroot\craft\app\framework\web\CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#10 C:\inetpub\wwwroot\craft\app\framework\web\CWebApplication.php(282): CController->run('sendMessage')
#11 C:\inetpub\wwwroot\craft\app\etc\web\WebApp.php(805): CWebApplication->runController('contactForm/sen...')
#12 C:\inetpub\wwwroot\craft\app\etc\web\WebApp.php(275): Craft\WebApp->_processActionRequest()
#13 C:\inetpub\wwwroot\craft\app\framework\base\CApplication.php(184): Craft\WebApp->processRequest()
#14 C:\inetpub\wwwroot\craft\app\index.php(62): CApplication->run()
#15 C:\inetpub\wwwroot\public\index.php(14): require_once('C:\inetpub\wwwr...')
#16 {main} REQUEST_URI=/contact HTTP_REFERER=https://soho.infor.com/contact
--- 2015/12/03 19:21:27 [error] [application] SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Is, Some application not installed? Or something not configured? Or could it be a matter that this site requires authentication now to hit it in the browser (https redirects)?

Additionally where is the SMTP server configured?

-Tim

2

Craft's email SMTP settings are configured under Settings->Email in the control panel.

The error message you're getting:

2015/12/03 19:21:27 [error] [exception.phpmailerException] exception 'phpmailerException' with message 'SMTP connect() failed.

Simply means that PHP/Craft can't connect (for whatever reason) to the server you specified with whatever SMTP settings you've entered in Settings->Email.

Chances are the credentials are invalid or the settings are incorrect, but it can also happen is something (firewall, router, etc.) is blocking output SMTP access as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.