I just upgraded Craft to the latest version, and this error now shows up.

The file “myfile.jpg” could not be uploaded, because it exceeds the maximum upload size of 0 B

Any fix ? Everything worked fine before the update. Thanks !

  • Is this just 1 file or does it happen with all files?
    – Brad Bell
    Commented Jan 4, 2016 at 18:49
  • all the files, whatever their size is
    – ovesco
    Commented Jan 6, 2016 at 13:34
  • Enable devMode and try checking your craft/storage/runtime/logs files for any related upload errors.
    – Brad Bell
    Commented Jan 6, 2016 at 19:16
  • So I looked inside the craft.log file, removed everything inside and tried to upload a picture. From the moment when I click "upload file" to the selection of the file and then the javascript alert of 0 B, nothing is written inside the log file.
    – ovesco
    Commented Jan 7, 2016 at 15:32
  • Hrm... anything in your web server's error logs?
    – Brad Bell
    Commented Jan 7, 2016 at 18:58

1 Answer 1


I had the same problem, changing post_max_size in php.ini to something other than 0 (I used 8M) did it for me.

I'm not sure why this works: php.ini says a value of 0 should disable the limit altogether, and this was never an issue on my other Craft installs. Perhaps a bug?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.