0

I'm having a few irregular errors after upgrading via the automatic update. When trying to visit the dashboard I get:

Internal Server Error

Passed variable is not an array or object, using empty array instead

My max_execution_time and memory_limit are set pretty high, and I believe the upgrade completed successfully. But I cannot view the dashboard or settings pages. Everything else seems to be fine.

Do I have to fully revert and re-try the upgrade via the manual method?

4
  • If you enable devMode and load the page, it should show the full stack trace leading up to that error. Can you share that?
    – Brad Bell
    Dec 28, 2015 at 19:05
  • See, you're so smart. LOL. Once I did that, I could see that the Placid plugin was throwing the array error, likely trying to integrate something into the Dashboard page itself? That plugin wasn't critical to production anyway, so is fine to sit disabled. Thanks, Brad.
    – Neal Magee
    Dec 28, 2015 at 19:43
  • 1
    Haha... tell my wife that. :) Can you add that as an official answer?
    – Brad Bell
    Dec 28, 2015 at 19:44
  • 3
    Dear Brad's Wife: I'm sure Brad sometimes forgets to take out the trash, or leaves stuff sitting around more than you like, but really ... he fixes things, and is a good egg. He's helped me out more than once and I can attest that he's terribly smart. Please, believe me. ;-)
    – Neal Magee
    Dec 28, 2015 at 20:01

1 Answer 1

3

To answer my own question: There may be some plugin incompatibilities when upgrading to Craft 2.5. This is to be expected, given all the variables. In my case the Placid plugin was not yet compatible, as seen when I put Craft into devMode.

So either:

  1. Wait on the upgrade until your plugins are current, or
  2. Disable lagging plugins as necessary if you need the bleeding edge.
2
  • 1
    This was an issue with earlier versions of Placid, you're correct. The latest version of the plugin has this issue addressed github.com/alecritson/Placid/releases/tag/1.6.16 Dec 29, 2015 at 12:54
  • Alec, thanks so much for letting me know. I'll go ahead and re-enable Placid then, and continue work with it.
    – Neal Magee
    Dec 29, 2015 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.