2

After recently discovering the logs for Sprout forms (located in craft/storage/runtime/logs) I have been studying them and debugging new forms that I am creating.

After integrating a form hook in my templates, I am getting an error: A form submission failed because the user did not have Javascript enabled. - but I do have Javascript enabled... it is prevalent on other parts of the page.

Any tips... ?

  • Do you have any captcha plugins installed? Can you try disabling them. – Ben Parizek Dec 22 '15 at 17:57
  • I am using invisiblecaptcha by you guys, Sprout... – Adam Menczykowski Dec 22 '15 at 17:57
  • This is likely an Invisible Captcha bug. Can you disable it and see if you can get things working? – Ben Parizek Dec 22 '15 at 18:19
  • Yes completely disabling the invisible Captcha allows the form to trigger the email to send. Previous to disabling it, I also had an error: [info] [plugin] [Forced] A form submission failed the Duplicate Submission test. – Adam Menczykowski Dec 23 '15 at 11:54
  • Adam, we're unable to recreate this bug. Can you tell us more about what "after integrating a form hook in my templates" means? – Ben Parizek Jan 16 '16 at 2:19
2

Probably you are caching the page. You can't cache a sprout form. The csrf will be the same for all the users.

1

Disabling Sprout invisible captcha fixed this.

Please let me know if there is an update to this fieldtype plugin to fix this. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.