1

I am trying to install Craft CMS 2.5 on a Windows 10 machine using WAMP 2.5.

I just downloaded both Craft and WAMP this morning — so both are fresh installs.

I believe I have done everything properly, but when I navigate to localhost/sitename/public I get the following message:

Service Unavailable

Our site is temporarily unavailable. Please try again later.

If I try navigating to localhost/sitename/public/admin OR localhost/sitename/admin I get the following message:

Not Found

The requested URL /sitename/admin was not found on this server.

Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

These are the steps I took when setting up:

  1. Created a folder in wamp/www called sitename
  2. Copied the craft and public folders into the sitename folder
  3. Changed htaccess to .htaccess (using windows command line)
  4. Created database in phpmyadmin
  5. Updated db.php in craft/config folder

(the only change I had to make was to add the database name — I left server as localhost, user as root and password blank. I did change the tablePrefix to five different letters — i.e., no numbers or special characters)

I did NOT change the permissions on any of the app, config or storage folders for the simple reason that I do not know how to do that on Windows.

Unless the permissions are the problem, then I do not know why I am having this problem.

Any ideas?

  • 2
    Do you get anything if you do localhost/sitename/public/index.php/admin? It looks like your doc root is not the public folder and your .htaccess file is what does the rewrite of your urls to make them 'pretty' – Alec Ritson Dec 15 '15 at 13:47
  • @Moshe Can you add the solution that worked for you as an official answer? – Brad Bell Dec 15 '15 at 17:45
1

Alec Ritson's comment solved the problem. His advice was to try

localhost/sitename/public/index.php/admin

In other words, I had to add index.php to the URL (after public but before admin) and then everything worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.