1

Hi I've just updated to Craft 2.5 but ran into a problem. All my assets are now broken (also showen broken assets icons). I've cleared my cache, went to my craft_tasks table and adjusted the running task there but still it won't show me my assets again...

Any suggestions someone?

  • Are you on an Ubuntu 14.04 server? – Steve Adams Dec 3 '15 at 14:02
  • Just downgraded to 2.4.2726 and everything works again... – Jeromes Dec 3 '15 at 15:20
  • Can you submit a ticket from your dashboard's Get Help widget and let it send along your log files? – Brad Bell Dec 3 '15 at 17:03
1

I had similar issue but I was tinkering with Elements API. The JSON payload gave me that cpresources/transforms/ but once I clicked on the link it shows the proper image with the transforms applied.

Upon returning to the JSON printout, the URL for the assets looks correct. In my case it is pointing to the S3 bucket I had setup previously.

| improve this answer | |
1

Do you have any transforms configured?

I would double check your asset source File System Path is correct. Before 2.5 I had mine set incorrectly but image.url('<transform_handle>') still worked.

Also, try to upload an image through an asset field and see if you get any errors.

| improve this answer | |
0

At any point did you have to add the line extension=imagick.so in your php.ini file? Even though it was recommended by my webhost (Fused Network) at the time , it was causing ImageMagick to misbehave and filling my public_html directory with core dumps. They were able to figure out the problem and deleting that line solved it.

| improve this answer | |
  • 1
    Just to be clear this will disable Imagick all-together and you'll be falling back to using GD. – Brad Bell Dec 4 '15 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.