1

I've set up some dynamic routes to work with categories, so for example the route is set up to load a specific template if the work category appears in the URI, thus:

news-events/image-gallery/category/[slug]

However, if I test with the following URL I get a 404 error:

/news-events/image-gallery/category/drama

Other dynamic routes are working fine. Thoughts on how to debug/resolve appreciated.

Cole

1

I ran into a similar problem with categories and routing a while ago and Marion's answer in this thread worked for me

How would I include the first category slug in the section's entry URL format?

Darrell

| improve this answer | |
  • Thanks Darrell Not sure if that is the same problem - I have a URI with category in it (not category name) followed by the category slug. Have got working in other contexts but in this instance is throwing a 404 error :( – Cole Henley Nov 30 '15 at 13:01
  • Silly questions but are all your categories coming from one group? If you have multiple groups, do they all have "Categories in this group have their own URLs" ticked? Just troubleshooting ;) – Oli Nov 30 '15 at 14:06
  • More silly questions but is your template path correct in your route? – kcolls Dec 2 '15 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.