I want to setup a new custom subdomain (va.domain.com) within the project of my existing domain (craft.domain.com) using homestead.

So I referred to this this answer on craftexchange and followed all the steps.

I now have a separate folder at the root level called public_va. Inside that I have my index.phpwith this define statement that is supposed to change the path:

define('CRAFT_TEMPLATES_PATH', realpath(dirname(__FILE__) . "/../templates_va").'/');

Inside of the craftfolder I have created a folder called templates_va that is a sibling of the existing templates folder. And I put in a simple index.html file in just for testing.

Now when I point my browser to va.domain.com, it just shows me:

Page Not Found

The requested URL was not found on this server.

I also tried creating a new (single) section called va_homepage in the CP backend but I get the same error.

What am I doing wrong? How do I fix this? My error logs inside my vagrant box show nothing. The domain itself has been setup correctly via homestead. I verified by routing request to a static file.

1 Answer 1


This is now fixed. The dynamic path to the new templates folder was wrong:

define('CRAFT_TEMPLATES_PATH', realpath(dirname(__FILE__) . "/../templates_va").'/');

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.