2

If I create an entry with international characters in urls? e.g. for Polish language?

If I create an entry with the word "ułatwienia" in the url, it doesn't work (I get Craft serving up the 404 page), I take out the special ł character and it's fine.

Although interestingly, the Live Preview url works fine with the special character included.

Have I missed something?

1 Answer 1

1

That should work fine and I just tested locally with a fresh Craft installation on the latest build and ułatwienia works in the slug for me.

Maybe you've got the limitAutoSlugsToAscii config setting set to true and ł gets changed to l in the slug, but you're still entering ł in the URL?

2
  • Checked if this was option was set but it wasn't and explicity setting it to false didn't change anthing.I wondered if this was relating to my hosting on Windows/IIS since I was seeing the ł character being replaced with ? in the craft logs for the request. I've just moved my setup to a LAMP server, no other changes, and its working fine. Thanks
    – Ieuan
    Commented Sep 28, 2015 at 7:36
  • Possible, I suppose. I've got a Windows/IIS box I'll test on to make sure.
    – Brad Bell
    Commented Sep 28, 2015 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.