1

EDIT after resolving: offtopic since the issue was that the php extension for ImageMagick was not installed on the server - therefore not Craft-related.

Because .gif's were not being transformed properly (only the first frame) I figured ImageMagick was not doing the image transforms.

Therefore I updated the general config file with the line to set the imageDriver to ImageMagick ('imageDriver' => 'imagick'). However, as from that point whenever I tried to upload an asset in the control panel, the black loading bar appeared, instantly full, and the loading icon in the top right kept spinning. The loading bar did not disappear, nor did the file get uploaded.

As soon as I removed this line from the general config, the uploading worked as normal again.

I have tested my server and ImageMagick is installed (v6.8.3-6). I am running PHP 5.4.

I am not running any plugins. The only other setting I have in the general config file is 'generateTransformsBeforePageLoad' => true

Does anybody know what could cause this issue? I would like to use ImageMagick for all the transfers, but of course especially for the .gif's.

| improve this question | | | | |
  • 1
    Are you sure Imagick is enabled for PHP to use? If you go to yourdomain.com/admin/utils/phpinfo and search for imagick you should be able to see if there. – Brad Bell Sep 23 '15 at 19:50
  • Hi Brad, thanks for the reply. I browsed to that link and searched for "imagick" on that page, but the search did not return any results. I have contacted my hosting provider and he confirms that ImageMagick is installed on the server with "standard implementation". When I click on the "Server Info" tab of the page you linked, I can see an orange triangle with exclamation mark in it next to "ImageMagick extension" (on hover it displays "Passed with warning"). – Mitchell Sep 24 '15 at 18:29
  • If imagick doesn't show up when you go to admin/utils/phpinfo, then it's not available for PHP to use. They might have installed only the library, but not the PHP extension for it (secure.php.net/manual/en/book.imagick.php). – Brad Bell Sep 24 '15 at 18:50
  • 1
    No worries... I'm going to go ahead and vote to close this, then. Also, you should find a new hosting provider. ;) – Brad Bell Sep 27 '15 at 3:11
  • 1
    I'm voting to close this question as off-topic because the host is unwilling to install Imagick. – Brad Bell Sep 27 '15 at 3:13

Browse other questions tagged or ask your own question.