0

Here's the error I get: "You have an insecure version of crypt installed. Please update PHP to 5.3.7 or later". I have PHP Version 5.3.2 installed on my Ubuntu server and cannot switch to a new version no matter what I do. I also tried to php5enmod mcrypt and it gives me command not found. I did the classic

sudo apt-get update; sudo apt-get install php5; sudo apt-get install php5-mcrypt;

Can you guys help? My phpinfo() doesnt show mcrypt as being installed even though it is installed actually. I am out of ideas

2

I would install PHP via a third-party repository. I use Ondřej Surý's and I'm pretty happy with it. It installs PHP 5.5.

https://launchpad.net/~ondrej/+archive/ubuntu/php5

7
  • I did that and I'm still at PHP 5.3. Here's the exact terminal commands I executed: Sep 9 '15 at 15:21
  • sudo add-apt-repository ppa:ondrej/php5-oldstable; sudo apt-get update; sudo apt-get install php5 Sep 9 '15 at 15:21
  • I'm not sure how you're getting 5.3 because the php5-oldstable is 5.4. Why not use the latest php5 repository? Also, what version of Ubuntu are you using? Sep 9 '15 at 15:25
  • I have a Ubuntu 10.04.4 LTS server and I did try using the latest php5 repository Sep 9 '15 at 15:28
  • That is your problem right there. Ubuntu 10.04 is not supported in either of those repositories. The more recent one supports 12.04 and up and the oldstable only supports 12.04. Ubuntu is seeing that and falling back on it's own php5 package which is probably 5.3.2. You need to update Ubuntu. Sep 9 '15 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.